PHP, which is a recursive acronym for PHP: Hypertext Preprocessor, is amongst the most commonly used general-purpose programming languages that are available out there. Any site or Internet application based on PHP will run on a given server as long as a PHP module is installed, which renders the language really universal and it’s not really all that surprising that there are actually several million web servers that support it and hundreds of millions of PHP-driven sites hosted on them. What makes PHP preferred over HTML is the fact that it permits you to develop a dynamic serving site with plenty of different options. A PHP-based social networking site, for instance, will display unique content to each user in spite of the fact that the page URL will remain the same. In comparison, HTML-based sites are static and the page content can be edited only manually. Like any other software, PHP has several versions and the one that was used whilst creating a certain website must be available on the server in order for the site to work faultlessly.

PHP 4 and PHP 5 Support in Shared Website Hosting

We have made the decision not to prevent our present and future customers from selecting the PHP version that will be used by their sites, which implies that if you get a shared website hosting package from our company, you’ll be able to select between versions 5.5, 5.4, 5.3, 5.2 and 4, not only for the account as a whole, but also for each domain that you host. This can be done with only one mouse click through our in-house built Hepsia Control Panel via which all shared hosting accounts are administered, which is why you won’t need to have any programming or technical skills. You will be able to manage sites based on both new and old scripts without having to cope with any problems, so if you’d like to leave your current web hosting services provider and migrate over to us, you can be sure that all the websites that you have set up throughout the years will continue to work flawlessly.

PHP 4 and PHP 5 Support in Semi-dedicated Hosting

In case you have a site built using an earlier PHP version and you’ve committed time and effort into developing it, fixing security gaps and publishing web content, you’ll need a hosting service that can support it, as almost all hosting vendors nowadays offer only the most recently unveiled version of PHP and abandon the older versions. We, on the other hand, have decided to allow you to pick the exact version that your own websites need. Our Linux semi-dedicated hosting support PHP 4 and multiple versions of PHP 5, so you’ll be able to run both older and newer scripts without forfeiting any custom tweaks or misspending time and effort attempting to make your sites compatible with the web hosting environment. The version can be changed through the Hepsia Control Panel and such an update will affect the entire account, but you’ll also have the ability to choose a different version of PHP for each individual site hosted in your account using an .htaccess file.